«The requested package php could not be found in any version»

0.42.0-beta1
composer
(Дмитрий Федюк) #1

При выполнении команды composer install в контексте установке Magento 2 работа Composer может завершиться сбойно с диагностическим сообщением:

The requested package php could not be found in any version.

Это диагностическое сообщение означает, что имеющаяся у Вас версия интерпретатора PHP не не отвечает диапазону допустимых разработчиками Magento 2 версий.

В файле composer.json дистрибутива Magento 2 версии 0.42.0-beta1 диапазон допустимых версий интерпретатора PHP описан так:

"php": "~5.4.11|~5.5.0"

Эта запись означает, что допустимы версии интерпретатора PHP не ниже 5.4.11 и ниже 5.6.0.
Проверьте, какая версия интерпретатора PHP установлена у Вас.

  • Если у Вас версия ниже 5.4.11, то Вам однозначно нужно обновить интерпретатор PHP перед установкой Magento 2.
  • Если же у Вас версия интерпретатора PHP 5.6 или новее, то понижать версию интерпретатора PHP не нужно (я на практике проверил, что Magento 2 вполне совместима с PHP 5.6) и вместо понижения версии интерпретатора PHP уберите ограничение версии интерпретатора PHP.
0 Likes