Как установить Magento 2 при использовании PHP 5.6

0.42.0-beta1
php
composer
системные-требования

(Дмитрий Федюк) #1

Magento 2 версии 0.42 официально не поддерживает версии интерпретатора PHP 5.6 и новее.
Однако мой опыт показал, что Magento 2 совместима с PHP 5.6.
При попытке установки Magento командой composer install и использовании интерпретатора PHP версии 5.6 Composer откажется производить установку и завершит работу с диагностическим сообщением:

The requested package php could not be found in any version.

Чтобы Composer не останавливал свою работу с подобным замечанием, необходимо удалить верхнее ограничение версии интерпретатора PHP:

  1. В корневой папке Magento 2 найдите файл composer.json и замените там строку

    "php": "~5.4.11|~5.5.0"
    

    на строку

    "php": ">=5.4.11"
    
  • Если в корневой папке Magento 2 присутствует файл composer.lock — то удалите его.

Обратите внимание, что у каждого из системных модулей есть свой файл composer.json (например: app/code/Magento/AdminNotification/composer.json) и там тоже присутствует ограничение на версию интерпретатора PHP, однако редактировать эти файлы не нужно: корневой composer.json обладает приоритетом, достаточно отредактировать лишь его.


(Дмитрий Федюк) #2

Magento 2 версии 0.74 уже официально поддерживает PHP 5.6, и инструкция выше не нужна.