«Could not fetch <объект>, enter your GitHub credentials to go over the API rate limit»

composer
github
0.42.0-beta1

(Дмитрий Федюк) #1

При выполнении команды composer install в контексте установке Magento 2 работа Composer может прерваться с диагностическим сообщением:

Could not fetch <объект>, enter your GitHub credentials to go over the API rate limit.

В такой ситуации Composer запрашивает у Вас логин и пароль Вашей учётной записи на GitHub, и надо ввести их для продолжения установки.
Если у Вас нет ещё учётной записи на GitHub, то просто заведите её.

Возможна ситуация, когда при вводе правильных логина и пароля для GitHub авторизация не будет проходить и Composer будет писать «Could not fetch https://api.github.com/authorizations». В таком случае следуйте инструкции.