«Could not fetch https://api.github.com/authorizations»

composer
0.42.0-beta1
github
сбой

(Дмитрий Федюк) #1

При выполнении команды composer install в контексте установке Magento 2 работа Composer может прерваться с диагностическим сообщением:

Could not fetch https://api.github.com/authorizations.

Composer запрашивает у Вас логин и пароль Вашей учётной записи на GitHub, однако когда Вы их вводите, то Composer пишет то же самое диагностическое сообщение, то есть авторизация не проходит.
В такой ситуации нужно сделать следующее:

  1. Авторизоваться на сайте GitHub.
  • Создать токен для Composer.

  • В файле composer.json корневой папки Magento найти секцию config и внутри нее указать Ваш токен следующим образом:

      "github-oauth": {
          "github.com": "<Ваш токен>"
      }
    
  • Выполнить команду composer install заново.